通达信指标公式板王短线主图指标

股票实战家股票学习2019-10-09 14:34:3321
通达信指标公式板王短线主图指标

停:=IF((C-REF(C,1))/REF(C,1)*100 =9.90 AND C O,1,0);
STICKLINE(停,O,C,2.0,0),COLORRED;
STICKLINE(停,H,L,0,0),COLORRED;
STICKLINE(停,O,C,1.5,0),COLORYELLOW;
M5:MA(CLOSE,5), COLORWHITE;
M10:MA(C,10),COLORYELLOW;
M20:MA(C,20),COLORMAGENTA;
M30:MA(C,30),COLORCYAN;
M60:MA(C,60),COLORGREEN;
M120:MA(C,120),COLORRED;
M250:MA(C,250),COLORGRAY;
涨停:=IF((C-REF(C,1))/REF(C,1)*100 =9.90,1,0);
涨停板:=(C-REF(C,1))/REF(C,1)*100 =9.90 AND C IF(BARSCOUNT(C) 20,M10,IF(BARSCOUNT(C) =60,M60,M20));
TU:=IF(C =O,C,O);
UT:=IF(C =O,O,C);
上影:(H-TU)/TU*100,NODRAW,COLORRED;
低开%:IF(O REF(C,1),(O-REF(C,1))/REF(C,1)*100,0),NODRAW,COLORCYAN;
换手率:=VOL/CAPITAL,NODRAW;
大阳:=C =O AND (C-REF(C,1))/REF(C,1)*100
K线根数:=BARSCOUNT(C),NODRAW;
CX:=IF(BARSCOUNT(C) 60,60,3),NODRAW;{次新股除外}
跳空:=L REF(H,1) AND (C-REF(C,1))/REF(C,1)*100 =9.90 AND C IF(BARSCOUNT(C) 20,M10,IF(BARSCOUNT(C) =60,M60,M20));
去大中阴线:=(C-O)/O*100 -5 OR (C-REF(C,1))/REF(C,1)*100
去除连续两阴:=IF((REF(C,1) REF(O,1) AND REF(C,1) REF(C,2) AND REF(C,2) REF(O,2) AND (REF(C,1)-REF(O,2))/REF(O,2)*100 =-5) OR (REF(C,2) REF(O,2) AND (REF(C,1)-REF(O,2))/REF(O,2)*100 =-5 AND REF(C,1) REF(O,1)),1,0),NODRAW;
三只乌鸦:=C O AND REF(C,1) REF(O,1) AND REF(C,2) REF(O,2),NODRAW;
昨三只乌鸦:=COUNT(REF(三只乌鸦,1),1) =1,NODRAW; {涨停后第四天}
前三只乌鸦:=COUNT(REF(三只乌鸦,1),2) =1,NODRAW;{涨停后第五天}
六天三乌鸦:=COUNT(REF(三只乌鸦,1),3) =1,NODRAW;{涨停后第六天}
七天三乌鸦:=COUNT(REF(三只乌鸦,1),4) =1,NODRAW;{涨停后第七天}
八天三乌鸦:=COUNT(REF(三只乌鸦,1),5) =1,NODRAW;{涨停后第八天}
九天三乌鸦:=COUNT(REF(三只乌鸦,1),6) =1,NODRAW;{涨停后第八天}
{第一种情况:长上影}
长上影:=上影 =3 AND H=HHV(H,10) AND C =O AND C=HHV(C,10) AND MA(C,5) MA(C,10) AND MA(C,10) MA(C,20),NODRAW; {AND C O}
去长上影阴线:=IF((C-H)/H*100 -6 AND C =O AND 跳空=0,1,0),NODRAW;
跳空长上影0:=跳空 AND 长上影 AND COUNT(REF(去长上影阴线,1),5)=0 ;
跳空长上影1:=REF(跳空,1) AND 长上影 AND COUNT(REF(去长上影阴线,1),5)=0 ; { AND REF(停,1)=0}
跳空长上影2:=REF(跳空,2) AND REF(L,1) REF(H,3) AND 长上影 AND COUNT(REF(去长上影阴线,1),5)=0 ; { AND REF(停,2)=0}
跳空长上影3:=REF(跳空,3) AND REF(L,1) REF(H,4) AND REF(L,2) REF(H,4) AND 长上影 AND COUNT(REF(去长上影阴线,1),5)=0 ; { AND REF(停,3)=0}
跳空长上影4:=REF(跳空,4) AND REF(L,1) REF(H,5) AND REF(L,2) REF(H,5) AND REF(L,3) REF(H,5) AND 长上影 AND COUNT(REF(去长上影阴线,1),5)=0 ; { AND REF(停,4)=0}
跳空长上影:=跳空长上影0 OR 跳空长上影1 OR 跳空长上影2 OR 跳空长上影3 OR 跳空长上影4,COLORYELLOW,NODRAW;
{第二种情况:实体大阳}
实体大阳:=大阳 AND H=HHV(H,10) AND C =O AND C=HHV(C,10) AND MA(C,5) MA(C,10) AND MA(C,10) MA(C,20),NODRAW; {AND C O}
跳空大阳1:=REF(跳空,1) AND 实体大阳 ; { AND REF(停,1)=0 AND COUNT(REF(去长上影阴线,1),5)=0}
跳空大阳2:=REF(跳空,2) AND REF(L,1) REF(H,3) AND 实体大阳 ; { AND REF(停,2)=0 AND COUNT(REF(去长上影阴线,1),5)=0 }
跳空大阳3:=REF(跳空,3) AND REF(L,1) REF(H,4) AND REF(L,2) REF(H,4) AND 实体大阳 ; { AND REF(停,3)=0 AND COUNT(REF(去长上影阴线,1),5)=0}
跳空大阳4:=REF(跳空,4) AND REF(L,1) REF(H,5) AND REF(L,2) REF(H,5) AND REF(L,3) REF(H,5) AND 实体大阳 ; { AND REF(停,4)=0 AND COUNT(REF(去长上影阴线,1),5)=0}
跳空大阳:=跳空大阳1 OR 跳空大阳2 OR 跳空大阳3 OR 跳空大阳4,COLORYELLOW,NODRAW; {跳空大阳0 OR}
买点:=IF(O =REF(C,1) AND (REF(C,1)-O)/O*100 =3.5,O,IF(O REF(C,1) AND L =REF(C,1) AND (REF(C,1)-L)/L*100 =3.5,REF(C,1)*0.94,DRAWNULL)),COLORYELLOW,NODRAW;
买点1:=IF(O =REF(C,2) AND (REF(C,2)-O)/O*100 =3.5,O,IF(O REF(C,2) AND L =REF(C,2) AND (REF(C,2)-L)/L*100 =3.5,REF(C,2)*0.94,DRAWNULL)),COLORYELLOW,NODRAW;
STICKLINE((REF(跳空长上影,1) OR REF(跳空大阳,1)) AND L =买点 AND COUNT(REF(涨停,1),10) =CX AND COUNT(REF(去大中阴线,1),2)=0 AND (O-REF(C,1))/REF(C,1)*100 =1.5,买点,买点,3.5,0),COLORYELLOW;
买一:=IF((REF(跳空长上影,1) OR REF(跳空大阳,1)) AND L =买点 AND COUNT(REF(涨停,1),10) =CX AND COUNT(REF(去大中阴线,1),2)=0 AND (O-REF(C,1))/REF(C,1)*100 =1.5,买点,DRAWNULL),NODRAW,COLORYELLOW;
STICKLINE((REF(跳空长上影,2) OR REF(跳空大阳,2)) AND L =买点1 AND REF(L,1) REF(C,2) AND L =REF(C,2) AND 买点1 AND 买一=0 AND COUNT(REF(涨停,1),10) =CX AND COUNT(REF(去大中阴线,1),3)=0 AND (O-REF(C,1))/REF(C,1)*100 =1.5,买点1,买点1,3.5,0),COLORYELLOW;
买二:=IF((REF(跳空长上影,2) OR REF(跳空大阳,2)) AND L =买点1 AND REF(L,1) REF(C,2) AND L =REF(C,2) AND 买一=0 AND 买点1 AND COUNT(REF(涨停,1),10) =CX AND COUNT(REF(去大中阴线,1),3)=0 AND (O-REF(C,1))/REF(C,1)*100 =1.5,买点1,DRAWNULL),NODRAW,COLORYELLOW;
STICKLINE((REF(跳空长上影,1) OR REF(跳空大阳,1)) AND (REF(C,1)-O)/O*100 =3.5 AND L =REF(O,1) AND 买一=0 AND 买二=0 AND COUNT(REF(涨停,1),10) =CX AND COUNT(REF(去大中阴线,1),4)=0 AND (O-REF(C,1))/REF(C,1)*100 =1.5,IF(O REF(O,1),O,REF(O,1)),IF(O REF(O,1),O,REF(O,1)),3.5,0),COLORYELLOW;
买三:=IF((REF(跳空长上影,1) OR REF(跳空大阳,1)) AND (REF(C,1)-O)/O*100 =3.5 AND L =REF(O,1) AND 买一=0 AND 买二=0 AND COUNT(REF(涨停,1),10) =CX AND COUNT(REF(去大中阴线,1),4)=0 AND (O-REF(C,1))/REF(C,1)*100 =1.5,IF(O REF(O,1),O,REF(O,1)),DRAWNULL),NODRAW,COLORWHITE;
STICKLINE((REF(跳空长上影,2) OR REF(跳空大阳,2)) AND (REF(C,1)-O)/O*100 =3.5 AND REF(L,1) REF(O,2) AND L =REF(O,2) AND COUNT(REF(涨停,1),10) =CX AND COUNT(REF(去大中阴线,1),5)=0 AND (O-REF(C,1))/REF(C,1)*100 =1.5,IF(O =REF(O,2) AND 买一=0 AND 买二=0 AND 买三=0,O,REF(O,2)),IF(O =REF(O,2),O,REF(O,2)),3.5,0),COLORYELLOW;
买四:=IF((REF(跳空长上影,2) OR REF(跳空大阳,2)) AND (REF(C,1)-O)/O*100 =3.5 AND REF(L,1) REF(O,2) AND L =REF(O,2) AND 买一=0 AND 买二=0 AND 买三=0 AND COUNT(REF(涨停,1),10) =CX AND COUNT(REF(去大中阴线,1),5)=0 AND (O-REF(C,1))/REF(C,1)*100 =1.5,IF(O =REF(O,2),O,REF(O,2)),DRAWNULL),NODRAW,COLORWHITE;
缺口:买一 OR 买二 OR 买三 OR 买四,NODRAW,COLORYELLOW;
跳空上影低开:=(REF(跳空长上影,1) AND (O =REF(C,1) OR L =REF(C,1))) OR (REF(跳空长上影,2) AND REF(L,1) REF(C,2) AND L =REF(C,2)) OR (REF(跳空长上影,1) AND L =REF(O,1)) OR (REF(跳空长上影,2) AND REF(L,1) REF(O,2) AND L =REF(O,2)),NODRAW;
涨停实体:=IF(停,(C-O)/O*100,0),NODRAW,COLORYELLOW;
涨停后高开阴线:=IF(REF(涨停板,2) AND REF(O,1) =REF(C,2) AND REF(O,1) REF(C,1),1,0),NODRAW;
两日最高:=HHV(REF(H,1),2),NODRAW;
低开:IF((REF(涨停板,1) AND 低开% =-3.5 AND COUNT(REF(涨停板,1),10) =CX) OR (REF(涨停板,2) AND 涨停后高开阴线=0 AND 低开% =-3.5 AND (REF(C,1)-REF(O,1))/REF(O,1)*100 =-6 AND ((REF(C,1)-REF(C,2))/REF(C,2)*100 =3.5 OR (两日最高-O)/O*100 =8) AND COUNT(REF(涨停,1),10) =CX),O,0),NODRAW,COLORCYAN;{AND REF(C,1) REF(C,2)}
STICKLINE((REF(涨停板,1) AND 低开% =-3.5 AND COUNT(REF(涨停板,1),10) =CX) OR (REF(涨停板,2) AND 涨停后高开阴线=0 AND (REF(C,1)-REF(O,1))/REF(O,1)*100 =-6 AND ((REF(C,1)-REF(C,2))/REF(C,2)*100 =3.5 OR (两日最高-O)/O*100 =8) AND 低开% =-3.5 AND COUNT(REF(涨停,1),10) =CX),O,O,3.5,0),COLORCYAN;{AND REF(C,1) REF(C,2) }
低走:IF(REF(涨停板,1) AND (O-REF(C,1))/REF(C,1)*100 =1.5 AND (O-REF(C,1))/REF(C,1)*100 =-4.5 AND (L-REF(C,1))/REF(C,1)*100 =-5.5 AND 低开=0,IF(O REF(C,1)*0.945,O,REF(C,1)*0.945),DRAWNULL),NODRAW,COLORCYAN;
STICKLINE(REF(涨停板,1) AND (O-REF(C,1))/REF(C,1)*100 =1.5 AND (O-REF(C,1))/REF(C,1)*100 =-4.5 AND (L-REF(C,1))/REF(C,1)*100 =-5.5 AND 低开=0 AND L =低走,低走,低走,3.5,0),COLORCYAN;
实体涨停:=停 AND (C-O)/O*100 =7 AND C M5 ,NODRAW;{COUNT(M60 REF(M60,1),10) =6 AND M5 M60}
实体涨停1:=停 AND (C-O)/O*100 7 AND (C-L)/L*100 =7 AND C M5 ,NODRAW;{COUNT(M60 REF(M60,1),10) =6 AND M5 M60}
实体涨停双响:=REF(实体涨停,1) AND 停 AND ((C-O)/O*100 =6 OR (H-L)/L*100 =6) AND C M5,NODRAW;{6 OR (H-L)/L*100 =6)}
跌停:=(C-REF(C,1))/REF(C,1)*100
多周期跌停:=COUNT(REF(跌停,1),8)=0;
多周期涨停:=COUNT(REF(停,3),15)=0,NODRAW;
多周期涨停1:=COUNT(REF(停,4),15)=0;
多周期涨停2:=COUNT(REF(停,5),15)=0;
多周期涨停3:=COUNT(REF(停,6),15)=0;
多周期涨停4:=COUNT(REF(停,7),15)=0;
多周期涨停5:=COUNT(REF(停,8),15)=0;
多周期涨停6:=COUNT(REF(停,9),15)=0;
多周期涨停7:=COUNT(REF(停,10),15)=0;
多周期涨停00:=COUNT(REF(停,4),15)=0,NODRAW;
多周期涨停10:=COUNT(REF(停,5),15)=0;
多周期涨停20:=COUNT(REF(停,6),15)=0;
多周期涨停30:=COUNT(REF(停,7),15)=0;
多周期涨停40:=COUNT(REF(停,8),15)=0;
多周期涨停50:=COUNT(REF(停,9),15)=0;
多周期涨停60:=COUNT(REF(停,10),15)=0;
多周期涨停70:=COUNT(REF(停,11),15)=0;
回调买点:=IF(REF(O,2) =REF(C,3),REF(C,3),REF(O,2));
涨停回调买:=IF(REF(实体涨停,2) AND L =回调买点 AND 多周期涨停 AND 多周期跌停,IF(O =回调买点,O,回调买点),0),COLORWHITE,NODRAW;{涨停后第二天}
涨停回调买1:=IF(REF(实体涨停,3) AND L =REF(回调买点,1) AND 多周期涨停1 AND 多周期跌停 AND REF(涨停回调买,1)=0,IF(O =REF(回调买点,1),O,REF(回调买点,1)),0),COLORWHITE,NODRAW;{涨停后第三天}
涨停回调买2:=IF(REF(实体涨停,4) AND 昨三只乌鸦=0 AND L =REF(回调买点,2) AND 多周期涨停2 AND 多周期跌停 AND REF(涨停回调买1,1)=0 AND REF(涨停回调买,2)=0,IF(O =REF(回调买点,2),O,REF(回调买点,2)),0),COLORWHITE,NODRAW;{涨停后第四天}
涨停回调买3:=IF(REF(实体涨停,5) AND 前三只乌鸦=0 AND L =REF(回调买点,3) AND 多周期涨停3 AND 多周期跌停 AND REF(涨停回调买2,1)=0 AND REF(涨停回调买1,2)=0 AND REF(涨停回调买,3)=0,IF(O =REF(回调买点,3),O,REF(回调买点,3)),0),COLORWHITE,NODRAW;{涨停后第五天}
涨停回调买4:=IF(REF(实体涨停,6) AND 六天三乌鸦=0 AND L =REF(回调买点,4) AND 多周期涨停4 AND 多周期跌停 AND REF(涨停回调买3,1)=0 AND REF(涨停回调买2,2)=0 AND REF(涨停回调买1,3)=0 AND REF(涨停回调买,4)=0,IF(O =REF(回调买点,4),O,REF(回调买点,4)),0),COLORWHITE,NODRAW;{涨停后第六天}
涨停回调买5:=IF(REF(实体涨停,7) AND 七天三乌鸦=0 AND L =REF(回调买点,5) AND 多周期涨停5 AND 多周期跌停 AND REF(涨停回调买4,1)=0 AND REF(涨停回调买3,2)=0 AND REF(涨停回调买2,3)=0 AND REF(涨停回调买1,4)=0 AND REF(涨停回调买,5)=0,IF(O =REF(回调买点,5),O,REF(回调买点,5)),0),COLORWHITE,NODRAW;{涨停后第七天}
涨停回调买6:=IF(REF(实体涨停,8) AND 八天三乌鸦=0 AND L =REF(回调买点,6) AND 多周期涨停6 AND 多周期跌停 AND REF(涨停回调买5,1)=0 AND REF(涨停回调买4,2)=0 AND REF(涨停回调买3,3)=0 AND REF(涨停回调买2,4)=0 AND REF(涨停回调买1,5)=0 AND REF(涨停回调买,6)=0,IF(O =REF(回调买点,6),O,REF(回调买点,6)),0),COLORWHITE,NODRAW;{涨停后第八天}
涨停回调买7:=IF(REF(实体涨停,9) AND 九天三乌鸦=0 AND L =REF(回调买点,7) AND 多周期涨停7 AND 多周期跌停 AND REF(涨停回调买6,1)=0 AND REF(涨停回调买5,2)=0 AND REF(涨停回调买4,3)=0 AND REF(涨停回调买3,4)=0 AND REF(涨停回调买2,5)=0 AND REF(涨停回调买1,6)=0 AND REF(涨停回调买,7)=0,IF(O =REF(回调买点,7),O,REF(回调买点,7)),0),COLORWHITE,NODRAW;{涨停后第九天}
涨停回调买17:=涨停回调买 涨停回调买1 涨停回调买2 涨停回调买3 涨停回调买4 涨停回调买5 涨停回调买6 涨停回调买7,NODRAW;
涨停回调买00:=IF(REF(实体涨停双响,2) AND L =回调买点 AND 多周期涨停00 AND 多周期跌停 AND COUNT(涨停回调买17,1)=0,IF(O =回调买点 AND COUNT(涨停回调买17,1)=0,O,回调买点),0),COLORWHITE,NODRAW;{涨停后第二天}
涨停回调买10:=IF(REF(实体涨停双响,3) AND L =REF(回调买点,1) AND 多周期涨停10 AND 多周期跌停 AND COUNT(涨停回调买17,2)=0 AND REF(涨停回调买00=0,1),IF(O =REF(回调买点,1) AND COUNT(涨停回调买17,2)=0,O,REF(回调买点,1)),0),COLORWHITE,NODRAW;{涨停后第三天}
涨停回调买20:=IF(REF(实体涨停双响,4) AND L =REF(回调买点,2) AND 多周期涨停20 AND 多周期跌停 AND COUNT(涨停回调买17,3)=0 AND REF(涨停回调买00=0,2) AND REF(涨停回调买10=0,1),IF(O =REF(回调买点,2) AND COUNT(涨停回调买17,3)=0,O,REF(回调买点,2)),0),COLORWHITE,NODRAW;{涨停后第四天}
涨停回调买30:=IF(REF(实体涨停双响,5) AND L =REF(回调买点,3) AND 多周期涨停30 AND 多周期跌停 AND COUNT(涨停回调买17,4)=0 AND REF(涨停回调买00=0,3) AND REF(涨停回调买10=0,2) AND REF(涨停回调买20=0,1),IF(O =REF(回调买点,3) AND COUNT(涨停回调买17,4)=0,O,REF(回调买点,3)),0),COLORWHITE,NODRAW;{涨停后第五天}
涨停回调买40:=IF(REF(实体涨停双响,6) AND L =REF(回调买点,4) AND 多周期涨停40 AND 多周期跌停 AND COUNT(涨停回调买17,5)=0 AND REF(涨停回调买00=0,4) AND REF(涨停回调买10=0,3) AND REF(涨停回调买20=0,2) AND REF(涨停回调买30=0,1),IF(O =REF(回调买点,4) AND COUNT(涨停回调买17,5)=0,O,REF(回调买点,4)),0),COLORWHITE,NODRAW;{涨停后第六天}
涨停回调买50:=IF(REF(实体涨停双响,7) AND L =REF(回调买点,5) AND 多周期涨停50 AND 多周期跌停 AND COUNT(涨停回调买17,6)=0 AND REF(涨停回调买00=0,5) AND REF(涨停回调买10=0,4) AND REF(涨停回调买20=0,3) AND REF(涨停回调买30=0,2) AND REF(涨停回调买40=0,1),IF(O =REF(回调买点,5) AND COUNT(涨停回调买17,6)=0,O,REF(回调买点,5)),0),COLORWHITE,NODRAW;{涨停后第七天}
涨停回调买60:=IF(REF(实体涨停双响,8) AND L =REF(回调买点,6) AND 多周期涨停60 AND 多周期跌停 AND COUNT(涨停回调买17,7)=0 AND REF(涨停回调买00=0,6) AND REF(涨停回调买10=0,5) AND REF(涨停回调买20=0,4) AND REF(涨停回调买30=0,3) AND REF(涨停回调买40=0,2) AND REF(涨停回调买50=0,1),IF(O =REF(回调买点,6) AND COUNT(涨停回调买17,7)=0,O,REF(回调买点,6)),0),COLORWHITE,NODRAW;{涨停后第八天}
涨停回调买70:=IF(REF(实体涨停双响,9) AND L =REF(回调买点,7) AND 多周期涨停70 AND 多周期跌停 AND COUNT(涨停回调买17,8)=0 AND REF(涨停回调买00=0,7) AND REF(涨停回调买10=0,6) AND REF(涨停回调买20=0,5) AND REF(涨停回调买30=0,4) AND REF(涨停回调买40=0,3) AND REF(涨停回调买50=0,2) AND REF(涨停回调买60=0,1),IF(O =REF(回调买点,7) AND COUNT(涨停回调买17,8)=0,O,REF(回调买点,7)),0),COLORWHITE,NODRAW;{涨停后第九天}
回调买:=涨停回调买 涨停回调买1 涨停回调买2 涨停回调买3 涨停回调买4 涨停回调买5 涨停回调买6 涨停回调买7 涨停回调买00 涨停回调买10 涨停回调买20 涨停回调买30 涨停回调买40 涨停回调买50 涨停回调买60 涨停回调买70,NODRAW,COLORWHITE;
涨停回调0:=IF(回调买 AND COUNT(去除连续两阴,2)=0,回调买,DRAWNULL),COLORMAGENTA,NODRAW; { AND (回调买-REF(C,1))/REF(C,1)*100 =-4 }
STICKLINE(涨停回调0 ,涨停回调0,涨停回调0,3.5,0),COLORMAGENTA; { AND (回调买-REF(C,1))/REF(C,1)*100 =-4}
回调买点0:=IF(REF(L,2) =REF(C,3),REF(C,3),REF(L,2));
涨停回调买0:=IF(REF(实体涨停1,2) AND L =回调买点0 AND 多周期涨停 AND 多周期跌停,IF(O =回调买点0,O,回调买点0),0),COLORWHITE,NODRAW;{涨停后第二天}
涨停回调买01:=IF(REF(实体涨停1,3) AND L =REF(回调买点0,1) AND 多周期涨停1 AND 多周期跌停 AND REF(涨停回调买0,1)=0,IF(O =REF(回调买点0,1),O,REF(回调买点0,1)),0),COLORWHITE,NODRAW;{涨停后第三天}
涨停回调买02:=IF(REF(实体涨停1,4) AND L =REF(回调买点0,2) AND 多周期涨停2 AND 多周期跌停 AND REF(涨停回调买01,1)=0 AND REF(涨停回调买0,2)=0,IF(O =REF(回调买点0,2),O,REF(回调买点0,2)),0),COLORWHITE,NODRAW;{涨停后第四天}
涨停回调买03:=IF(REF(实体涨停1,5) AND L =REF(回调买点0,3) AND 多周期涨停3 AND 多周期跌停 AND REF(涨停回调买02,1)=0 AND REF(涨停回调买01,2)=0 AND REF(涨停回调买0,3)=0,IF(O =REF(回调买点0,3),O,REF(回调买点0,3)),0),COLORWHITE,NODRAW;{涨停后第五天}
涨停回调买04:=IF(REF(实体涨停1,6) AND L =REF(回调买点0,4) AND 多周期涨停4 AND 多周期跌停 AND REF(涨停回调买03,1)=0 AND REF(涨停回调买02,2)=0 AND REF(涨停回调买01,3)=0 AND REF(涨停回调买0,4)=0,IF(O =REF(回调买点0,4),O,REF(回调买点0,4)),0),COLORWHITE,NODRAW;{涨停后第六天}
涨停回调买05:=IF(REF(实体涨停1,7) AND L =REF(回调买点0,5) AND 多周期涨停5 AND 多周期跌停 AND REF(涨停回调买04,1)=0 AND REF(涨停回调买03,2)=0 AND REF(涨停回调买02,3)=0 AND REF(涨停回调买01,4)=0 AND REF(涨停回调买0,5)=0,IF(O =REF(回调买点0,5),O,REF(回调买点0,5)),0),COLORWHITE,NODRAW;{涨停后第七天}
涨停回调买06:=IF(REF(实体涨停1,8) AND L =REF(回调买点0,6) AND 多周期涨停6 AND 多周期跌停 AND REF(涨停回调买05,1)=0 AND REF(涨停回调买04,2)=0 AND REF(涨停回调买03,3)=0 AND REF(涨停回调买02,4)=0 AND REF(涨停回调买01,5)=0 AND REF(涨停回调买0,6)=0,IF(O =REF(回调买点0,6),O,REF(回调买点0,6)),0),COLORWHITE,NODRAW;{涨停后第八天}
涨停回调买07:=IF(REF(实体涨停1,9) AND L =REF(回调买点0,7) AND 多周期涨停7 AND 多周期跌停 AND REF(涨停回调买06,1)=0 AND REF(涨停回调买05,2)=0 AND REF(涨停回调买04,3)=0 AND REF(涨停回调买03,4)=0 AND REF(涨停回调买02,5)=0 AND REF(涨停回调买01,6)=0 AND REF(涨停回调买0,7)=0,IF(O =REF(回调买点0,7),O,REF(回调买点0,7)),0),COLORWHITE,NODRAW;{涨停后第九天}
涨停回调买18:=涨停回调买0 涨停回调买01 涨停回调买02 涨停回调买03 涨停回调买04 涨停回调买05 涨停回调买06 涨停回调买07;
涨停回调买000:=IF(REF(实体涨停双响,2) AND L =回调买点0 AND 多周期涨停00 AND 多周期跌停,IF(O =回调买点0,O,回调买点0),0),COLORWHITE,NODRAW;{涨停后第二天}
涨停回调买010:=IF(REF(实体涨停双响,3) AND REF(涨停回调买000,1)=0 AND L =REF(回调买点0,1) AND 多周期涨停10 AND 多周期跌停,IF(O =REF(回调买点0,1),O,REF(回调买点0,1)),0),COLORWHITE,NODRAW;{涨停后第三天}
涨停回调买020:=IF(REF(实体涨停双响,4) AND REF(涨停回调买010,1)=0 AND REF(涨停回调买000,2)=0 AND L =REF(回调买点0,2) AND 多周期涨停20 AND 多周期跌停,IF(O =REF(回调买点0,2),O,REF(回调买点0,2)),0),COLORWHITE,NODRAW;{涨停后第四天}
涨停回调买030:=IF(REF(实体涨停双响,5) AND REF(涨停回调买020,1)=0 AND REF(涨停回调买010,2)=0 AND REF(涨停回调买000,3)=0 AND L =REF(回调买点0,3) AND 多周期涨停30 AND 多周期跌停,IF(O =REF(回调买点0,3),O,REF(回调买点0,3)),0),COLORWHITE,NODRAW;{涨停后第五天}
涨停回调买040:=IF(REF(实体涨停双响,6) AND REF(涨停回调买030,1)=0 AND REF(涨停回调买020,2)=0 AND REF(涨停回调买010,3)=0 AND REF(涨停回调买000,4)=0 AND L =REF(回调买点0,4) AND 多周期涨停40 AND 多周期跌停,IF(O =REF(回调买点0,4),O,REF(回调买点0,4)),0),COLORWHITE,NODRAW;{涨停后第六天}
涨停回调买050:=IF(REF(实体涨停双响,7) AND REF(涨停回调买040,1)=0 AND REF(涨停回调买030,2)=0 AND REF(涨停回调买020,3)=0 AND REF(涨停回调买010,4)=0 AND REF(涨停回调买000,5)=0 AND L =REF(回调买点0,5) AND 多周期涨停50 AND 多周期跌停,IF(O =REF(回调买点0,5),O,REF(回调买点0,5)),0),COLORWHITE,NODRAW;{涨停后第七天}
涨停回调买060:=IF(REF(实体涨停双响,8) AND REF(涨停回调买050,1)=0 AND REF(涨停回调买040,2)=0 AND REF(涨停回调买030,3)=0 AND REF(涨停回调买020,4)=0 AND REF(涨停回调买010,5)=0 AND REF(涨停回调买000,6)=0 AND L =REF(回调买点0,6) AND 多周期涨停60 AND 多周期跌停,IF(O =REF(回调买点0,6),O,REF(回调买点0,6)),0),COLORWHITE,NODRAW;{涨停后第八天}
涨停回调买070:=IF(REF(实体涨停双响,9) AND REF(涨停回调买060,1)=0 AND REF(涨停回调买050,2)=0 AND REF(涨停回调买040,3)=0 AND REF(涨停回调买030,4)=0 AND REF(涨停回调买020,5)=0 AND REF(涨停回调买010,6)=0 AND REF(涨停回调买000,7)=0 AND L =REF(回调买点0,7) AND 多周期涨停70 AND 多周期跌停,IF(O =REF(回调买点0,7),O,REF(回调买点0,7)),0),COLORWHITE,NODRAW;{涨停后第九天}
涨停回调买19:=涨停回调买000 涨停回调买010 涨停回调买020 涨停回调买030 涨停回调买040 涨停回调买050 涨停回调买060 涨停回调买070;
回调买0:=涨停回调买18 涨停回调买19,NODRAW,COLORWHITE;
涨停实体0:=IF(停,(C-O)/O*100,0),NODRAW,COLORYELLOW;
涨停回调1:=IF(回调买0 AND 涨停回调0=DRAWNULL AND COUNT(去除连续两阴,2)=0,回调买0,DRAWNULL),COLORMAGENTA,NODRAW; { AND (回调买-REF(C,1))/REF(C,1)*100 =-4 AND COUNT(去除连续两阴,5)=0}
STICKLINE(涨停回调1 AND 涨停回调0=DRAWNULL,涨停回调1,涨停回调1,3.5,0),COLORMAGENTA; { AND (回调买-REF(C,1))/REF(C,1)*100 =-4}
十日最高:=HHV(REF(H,1),10);
十日最低:=LLV(REF(L,1),10);
十日跌幅:=(十日最高-十日最低)/十日最低*100
去高开低走阴线:=IF(C O AND O REF(C,1),1,0);
底部涨停:=实体涨停 AND 十日跌幅 AND (L-十日最低)/十日最低*100
底部回调买点1:=REF(底部涨停,1) AND L =REF(O,1) AND COUNT(去除连续两阴,1)=0; {AND 去高开低走阴线=0}
STICKLINE(底部回调买点1 ,IF(O =REF(O,1),O,REF(O,1)),IF(O =REF(O,1),O,REF(O,1)),3.5,0),COLORMAGENTA;
涨停回调2:=IF(REF(底部涨停,1) AND L =REF(O,1) ,IF(O =REF(O,1),O,REF(O,1)),0),NODRAW;
底部回调买点2:=REF(底部涨停,2) AND L =REF(O,2) AND REF(底部回调买点1,1)=0 AND COUNT(去除连续两阴,2)=0 ; {AND REF(去高开低走阴线,1)=0}
STICKLINE(底部回调买点2 ,IF(O =REF(O,2),O,REF(O,2)),IF(O =REF(O,2),O,REF(O,2)),3.5,0),COLORMAGENTA;
涨停回调3:=IF(底部回调买点2 ,IF(O =REF(O,2),O,REF(O,2)),0),NODRAW;
底部回调买点3:=REF(底部涨停,3) AND L =REF(O,3) AND REF(底部回调买点2,1)=0 AND REF(底部回调买点1,2)=0 AND COUNT(去除连续两阴,3)=0 ; {AND REF(去高开低走阴线,2)=0}
STICKLINE(底部回调买点3 ,IF(O =REF(O,3),O,REF(O,3)),IF(O =REF(O,3),O,REF(O,3)),3.5,0),COLORMAGENTA;
涨停回调4:=IF(底部回调买点3 ,IF(O =REF(O,3),O,REF(O,3)),0),NODRAW;
涨停回调:涨停回调0 OR 涨停回调1 OR 涨停回调2 OR 涨停回调3 OR 涨停回调4,NODRAW,COLORMAGENTA;
TP1:=REF(C,3)/REF(C,4) 1.095 AND REF(C,3)=REF(H,3);
TP2:=MAX(C,O)/MIN(C,O) 1.05 AND C/REF(C,1) 1.09;
TP3:=REF(O,2) REF(C,3) AND EVERY(MIN(C,O) REF(C,3),3);
三只喜鹊:=TP1 AND EVERY(TP2,3) AND TP3 AND 三只乌鸦=0 AND REF(C,3) IF(BARSCOUNT(C) 20,M10,IF(BARSCOUNT(C) =60,M60,M20));
取前实底:=IF(REF(C,1) =REF(O,1),REF(O,1),REF(C,1));
喜一:=IF(REF(三只喜鹊,1) AND O =取前实底,O,IF(REF(三只喜鹊,1) AND L =取前实底,取前实底,DRAWNULL)),NODRAW,COLORGREEN;
STICKLINE(REF(三只喜鹊,1) AND L =喜一 ,喜一,喜一,3.5,0),COLORGREEN;
三日实体底:=LLV(取前实底,3),NODRAW;
喜二:=IF(REF(三只喜鹊,1) AND O =三日实体底,O,IF(REF(三只喜鹊,1) AND L =三日实体底,三日实体底,DRAWNULL)),NODRAW,COLOR0088FF;
STICKLINE(REF(三只喜鹊,1) AND L =喜二 ,喜二,喜二,3.5,0),COLORGREEN;{COLOR0088FF;}
三日最低:=LLV(REF(L,1),3),NODRAW;
喜三:=IF(REF(三只喜鹊,1) AND O =三日最低,O,IF(REF(三只喜鹊,1) AND L =三日最低,三日最低,DRAWNULL)),NODRAW,COLORCYAN;
STICKLINE(REF(三只喜鹊,1) AND L =喜三 ,喜三,喜三,3.5,0),COLORGREEN;
喜四0:=IF(REF(三只喜鹊,2) AND O =REF(取前实底,2) ,O,IF(REF(三只喜鹊,2) AND L =REF(取前实底,2),REF(取前实底,2),DRAWNULL)),COLORGREEN;
喜四1:=IF(REF(三只喜鹊,2) AND REF(三只乌鸦,1)=0 AND REF(喜一,1)=DRAWNULL AND REF(喜二,1)=DRAWNULL AND REF(喜三,1)=DRAWNULL AND O =REF(取前实底,2),喜四0,IF(REF(喜一,1)!=DRAWNULL AND 喜四0 REF(喜一,1),喜四0,IF(REF(喜二,1)!=DRAWNULL AND 喜四0 REF(喜二,1),喜四0,IF(REF(喜三,1)!=DRAWNULL AND 喜四0 REF(喜三,1),喜四0,DRAWNULL)))),NODRAW,COLORGREEN;
STICKLINE(REF(三只喜鹊,2) AND REF(三只乌鸦,1)=0 AND L =喜四1,喜四1,喜四1,3.5,0),COLORGREEN;{AND REF(喜一,1)=0 AND REF(喜二,1)=0 AND REF(喜三,1)=0}
喜四:=IF(REF(三只喜鹊,2) AND REF(三只乌鸦,1)=0 AND L =喜四1,喜四1,0),COLORGREEN;
喜上眉梢:喜一 OR 喜二 OR 喜三 OR 喜四,NODRAW,COLORGREEN;
{五日内回踩十日线附近找买点}
涨板:=(C-REF(C,1))/REF(C,1)*100 =9.92 AND (C-M10)/M10*100 =5 AND C IF(BARSCOUNT(C) 20,M10,IF(BARSCOUNT(C) =60,M60,M20));
踩一:=IF(REF(涨板,1) AND L =M10*1.013 AND (REF(C,1)-L)/L*100 =5,IF(REF(C,1)*0.95 M10*1.013,REF(C,1)*0.95,M10*1.013),DRAWNULL),NODRAW,COLORWHITE;
踩一开:=IF(踩一=DRAWNULL,DRAWNULL,IF(O =踩一,O,踩一));
STICKLINE(REF(涨板,1) AND L =踩一开 AND (REF(C,1)-L)/L*100 =5 AND (O-REF(C,1))/REF(C,1)*100 =1.5,踩一开,踩一开,3.5,0),COLORWHITE;
十一:=IF(REF(涨板,1) AND L =踩一开 AND (REF(C,1)-L)/L*100 =5 AND (O-REF(C,1))/REF(C,1)*100 =1.5,踩一开,0),NODRAW,COLORRED;
踩二:=IF(REF(涨板,2) AND L =M10*1.013 AND (REF(C,2)-L)/L*100 =5 AND REF(踩一开,1)=DRAWNULL AND COUNT(REF(去大中阴线,1),1)=0,IF(REF(C,2)*0.95 M10*1.013,REF(C,2)*0.95,M10*1.013),DRAWNULL),NODRAW,COLORWHITE;
踩二开:=IF(踩二=DRAWNULL,DRAWNULL,IF(O =踩二,O,踩二));
STICKLINE(REF(涨板,2) AND L =踩二开 AND (REF(C,2)-踩二开)/踩二开*100 =5 AND REF(踩一开,1)=DRAWNULL AND COUNT(REF(去大中阴线,1),1)=0 ,踩二开,踩二开,3.5,0),COLORWHITE;
十二:=IF(REF(涨板,2) AND L =踩二开 AND (REF(C,2)-踩二开)/踩二开*100 =5 AND REF(踩一开,1)=DRAWNULL AND COUNT(REF(去大中阴线,1),1)=0 ,踩二开,0),NODRAW,COLORWHITE;
踩三:=IF(REF(涨板,3) AND L =M10*1.013 AND (REF(C,3)-L)/L*100 =5 AND REF(踩二开,1)=DRAWNULL AND REF(踩一开,2)=DRAWNULL AND COUNT(REF(去大中阴线,1),2)=0,IF(REF(C,3)*0.95 M10*1.013,REF(C,3)*0.95,M10*1.013),DRAWNULL),NODRAW,COLORWHITE;
踩三开:=IF(踩三=DRAWNULL,DRAWNULL,IF(O =踩三,O,踩三));
STICKLINE(REF(涨板,3) AND L =踩三开 AND (REF(C,3)-踩三开)/踩三开*100 =5 AND REF(踩二开,1)=DRAWNULL AND REF(踩一开,2)=DRAWNULL AND COUNT(REF(去大中阴线,1),2)=0 AND COUNT(去除连续两阴,1)=0 ,踩三开,踩三开,3.5,0),COLORWHITE;
十三:=IF(REF(涨板,3) AND L =踩三开 AND (REF(C,3)-踩三开)/踩三开*100 =5 AND REF(踩二开,1)=DRAWNULL AND REF(踩一开,2)=DRAWNULL AND COUNT(REF(去大中阴线,1),2)=0 AND COUNT(去除连续两阴,1)=0 ,踩三开,0),NODRAW,COLORWHITE;
踩四:=IF(REF(涨板,4) AND L =M10*1.013 AND (REF(C,4)-L)/L*100 =5 AND REF(踩三开,1)=DRAWNULL AND REF(踩二开,2)=DRAWNULL AND REF(踩一开,3)=DRAWNULL AND COUNT(REF(去大中阴线,1),3)=0,IF(REF(C,4)*0.95 M10*1.013,REF(C,4)*0.95,M10*1.013),DRAWNULL),NODRAW,COLORWHITE;
踩四开:=IF(踩四=DRAWNULL,DRAWNULL,IF(O =踩四,O,踩四));
STICKLINE(REF(涨板,4) AND 昨三只乌鸦=0 AND L =踩四开 AND (REF(C,4)-踩四开)/踩四开*100 =5 AND REF(踩三开,1)=DRAWNULL AND REF(踩二开,2)=DRAWNULL AND REF(踩一开,3)=DRAWNULL AND COUNT(REF(去大中阴线,1),3)=0 AND COUNT(去除连续两阴,2)=0 ,踩四开,踩四开,3.5,0),COLORWHITE;
十四:=IF(REF(涨板,4) AND 昨三只乌鸦=0 AND L =踩四开 AND (REF(C,4)-踩四开)/踩四开*100 =5 AND REF(踩三开,1)=DRAWNULL AND REF(踩二开,2)=DRAWNULL AND REF(踩一开,3)=DRAWNULL AND COUNT(REF(去大中阴线,1),3)=0 AND COUNT(去除连续两阴,2)=0,踩四开,0),NODRAW,COLORWHITE;
踩五:=IF(REF(涨板,5) AND L =M10*1.013 AND (REF(C,5)-L)/L*100 =5 AND REF(踩四开,1)=DRAWNULL AND REF(踩三开,2)=DRAWNULL AND REF(踩二开,3)=DRAWNULL AND REF(踩一开,4)=DRAWNULL AND COUNT(REF(去大中阴线,1),4)=0,IF(REF(C,5)*0.95 M10*1.013,REF(C,5)*0.95,M10*1.013),DRAWNULL),NODRAW,COLORWHITE;
踩五开:=IF(踩五=DRAWNULL,DRAWNULL,IF(O =踩五,O,踩五));
STICKLINE(REF(涨板,5) AND 前三只乌鸦=0 AND L =踩五开 AND (REF(C,5)-踩五开)/踩五开*100 =5 AND REF(踩四开,1)=DRAWNULL AND REF(踩三开,2)=DRAWNULL AND REF(踩二开,3)=DRAWNULL AND REF(踩一开,4)=DRAWNULL AND COUNT(REF(去大中阴线,1),4)=0 AND COUNT(去除连续两阴,3)=0 ,踩五开,踩五开,3.5,0),COLORWHITE;
十五:=IF(REF(涨板,5) AND 前三只乌鸦=0 AND L =踩五开 AND (REF(C,5)-踩五开)/踩五开*100 =5 AND REF(踩四开,1)=DRAWNULL AND REF(踩三开,2)=DRAWNULL AND REF(踩二开,3)=DRAWNULL AND REF(踩一开,4)=DRAWNULL AND COUNT(REF(去大中阴线,1),4)=0 AND COUNT(去除连续两阴,3)=0 ,踩五开,0),NODRAW,COLORWHITE;
板上长阳:=REF(涨停板,1) AND C O AND (C-REF(C,1))/REF(C,1)*100 5 AND (C-O)/O*100 =3.5; {涨停板第二天}
横五:=IF(REF(板上长阳,5) AND L =M10*1.013 AND (REF(C,5)-L)/L*100 =5,IF(REF(C,5)*0.95 M10*1.013,REF(C,5)*0.95,M10*1.013),DRAWNULL),NODRAW,COLORWHITE;
横五开:=IF(横五=DRAWNULL,DRAWNULL,IF(O =横五,O,横五));{,IF(O =横五,O,横五)}
STICKLINE(REF(板上长阳,5) AND L =横五开 AND (REF(C,5)-横五开)/横五开*100 =5 AND REF(C,1) =REF(C,6) AND REF(C,2) =REF(C,6) AND REF(C,3) =REF(C,6) AND REF(C,4) =REF(C,6) AND COUNT(REF(去大中阴线,1),4)=0 AND COUNT(去除连续两阴,3)=0 ,横五开,横五开,3.5,0),COLORWHITE;
板阳十五:=IF(REF(板上长阳,5) AND L =横五开 AND (REF(C,5)-横五开)/横五开*100 =5 AND REF(C,1) =REF(C,6) AND REF(C,2) =REF(C,6) AND REF(C,3) =REF(C,6) AND REF(C,4) =REF(C,6) AND COUNT(REF(去大中阴线,1),4)=0 AND COUNT(去除连续两阴,3)=0 ,横五开,0),NODRAW,COLORWHITE;
横六:=IF(REF(板上长阳,6) AND L =M10*1.013 AND (REF(C,6)-L)/L*100 =5,IF(REF(C,6)*0.95 M10*1.013,REF(C,6)*0.95,M10*1.013),DRAWNULL),NODRAW,COLORWHITE;
横六开:=IF(横六=DRAWNULL,DRAWNULL,IF(O =横六,O,横六));
STICKLINE(REF(板上长阳,6) AND REF(板阳十五,1)=DRAWNULL AND L =横六开 AND (REF(C,6)-横六开)/横六开*100 =5 AND REF(C,1) =REF(C,7) AND REF(C,2) =REF(C,7) AND REF(C,3) =REF(C,7) AND REF(C,4) =REF(C,7) AND REF(C,5) =REF(C,7) AND COUNT(REF(去大中阴线,1),5)=0 AND COUNT(去除连续两阴,4)=0 ,横六开,横六开,3.5,0),COLORWHITE;
板阳十六:=IF(REF(板上长阳,6) AND REF(板阳十五,1)=DRAWNULL AND L =横六开 AND (REF(C,6)-横六开)/横六开*100 =5 AND REF(C,1) =REF(C,7) AND REF(C,2) =REF(C,7) AND REF(C,3) =REF(C,7) AND REF(C,4) =REF(C,7) AND REF(C,5) =REF(C,7) AND COUNT(REF(去大中阴线,1),5)=0 AND COUNT(去除连续两阴,4)=0 ,横六开,0),NODRAW,COLORWHITE;
横七:=IF(REF(板上长阳,7) AND L =M10*1.013 AND (REF(C,7)-L)/L*100 =5,IF(REF(C,7)*0.95 M10*1.013,REF(C,7)*0.95,M10*1.013),DRAWNULL),NODRAW,COLORWHITE;
横七开:=IF(横七=DRAWNULL,DRAWNULL,IF(O =横七,O,横七));
STICKLINE(REF(板上长阳,7) AND REF(板阳十六,1)=DRAWNULL AND REF(板阳十五,2)=DRAWNULL AND L =横七开 AND (REF(C,6)-横七开)/横七开*100 =5 AND REF(C,1) =REF(C,8) AND REF(C,2) =REF(C,8) AND REF(C,3) =REF(C,8) AND REF(C,4) =REF(C,8) AND REF(C,5) =REF(C,8) AND REF(C,6) =REF(C,8) AND COUNT(REF(去大中阴线,1),6)=0 AND COUNT(去除连续两阴,5)=0 ,横七开,横七开,3.5,0),COLORWHITE;
板阳十七:=IF(REF(板上长阳,7) AND REF(板阳十六,1)=DRAWNULL AND REF(板阳十五,2)=DRAWNULL AND L =横七开 AND (REF(C,6)-横七开)/横七开*100 =5 AND REF(C,1) =REF(C,8) AND REF(C,2) =REF(C,8) AND REF(C,3) =REF(C,8) AND REF(C,4) =REF(C,8) AND REF(C,5) =REF(C,8) AND REF(C,6) =REF(C,8) AND COUNT(REF(去大中阴线,1),6)=0 AND COUNT(去除连续两阴,5)=0 ,横七开,0),NODRAW,COLORWHITE;
涨停踩十:十一 OR 十二 OR 十三 OR 十四 OR 十五 OR 板阳十五 OR 板阳十六 OR 板阳十七,NODRAW,COLORWHITE;

分享:

本文来自投稿,不代表本人立场,如若转载,请注明出处:http://www.vszj.net/article/38289.html

  通达信指标公式   涨停板   三只乌鸦