精准买卖点主图指标 源码 通达信 贴图 无加密 无未来

股票实战家股票学习2019-12-04 10:20:166
股票实战家(www.vszj.net)提示:您正在查看的是精准买卖点主图指标 源码 通达信 贴图 无加密 无未来

精准买卖点,无加密,无未来,源码分享!让你翱翔股海!
主图黄金分割可能有隐形未来,如果不喜欢删除即可!
高J:IF(CURRBARSCOUNT<=20,REFDATE(HHV(H,30),DATE),DRAWNULL),COLORWHITE,DOTLINE;
低J:IF(CURRBARSCOUNT<=20,REFDATE(LLV(L,30),DATE),DRAWNULL),COLORWHITE;

分割点1:IF(CURRBARSCOUNT<=10,高J-(高J-低J)*0.382,DRAWNULL),COLORWHITE,DOTLINE;
分割点2:IF(CURRBARSCOUNT<=10,高J-(高J-低J)*0.618,DRAWNULL),COLORWHITE,DOTLINE;
P1:=IF(BARSLAST(CURRBARSCOUNT=2),1,0);
DRAWTEXT(P1,分割点1,' 0.382'),COLORYELLOW;
DRAWTEXT(P1,分割点2,' 0.618'),COLORYELLOW;
DRAWTEXT(P1,低J,' XO'),COLORYELLOW;

G:=YEAR AND MONTH AND DAY;
G1:=STRCAT(CON2STR(YEAR,0),'年');
G2:=STRCAT(CON2STR(MONTH,0),'月');
G3:=STRCAT(CON2STR(DAY,0),'日');
G4:=STRCAT(' 【 ',IF(WEEKDAY=1,'星期一',IF(WEEKDAY=2,'星期二',IF(WEEKDAY=3,'星期三',IF(WEEKDAY=4,'星期四',IF(WEEKDAY=5,'星期五',IF(WEEKDAY=6,'星期六','星期日')))))));
GA:=STRCAT(STRCAT(STRCAT(G1,G2),STRCAT(G3,G4)),' 】');
日期:DRAWTEXT_FIX(G,0.04,0.03,0,GA)COLORGREEN;

TRR1:=MAX(MAX((HIGH-LOW),ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW));
ATRR:=MA(TRR1,13);
VARR1:=REF(CLOSE,1)-REF(ATRR,1);
LSX:HHV(VARR1,13),LINETHICK2,COLORWHITE;
LSX1:IF(C>=LSX,LSX,DRAWNULL),COLORRED,DOTLINE,LINETHICK2;

VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),2,1),COLORRED;
VARD:=CLOSE VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),2,0),COLORFFCC66;
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),3,1),COLORYELLOW;
VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),2,1.8),COLOR00FF00;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),2.6,0),COLOR00FFFF;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),2,0),COLOR00C8FF;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),1,0),COLOR10ECFF;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),2.6,0),COLOR00D900;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),2,0),COLOR93FFD1;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),1,0),COLOR93FF22;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),1,0),COLOR24FF22; 基础值:=IF(CREF(L,2),REF(C,2),IF(C>REF(C,1),C,REF(C,1)));
TOWER:=IF(VAR1A,REF(基础值,1),基础值); DRAWICON(VAR19=1,L*1.005,13);
DRAWICON(VAR1A=1,H*1.01,39);
DRAWNUMBER(VAR19,L*0.995,TOWER),COLORFFFFFF;
DRAWNUMBER(VAR1A,H*1.01,TOWER),COLORGREEN;

分享:

本文来自投稿,不代表本人立场,如若转载,请注明出处:http://www.vszj.net/article/49064.html

  精准买卖点主图指标 源码 通达信 贴图 无加密 无未来   通达信公式下载   股票公式  

精准买卖点主图指标 源码 通达信 贴图 无加密 无未来_相关内容