1. 首页
  2. 股票学习

好用的MACD幅图:MACD 看透主力+CCI副图指标 贴图 无加密 无未来

股票实战家(www.vszj.net)提示:您正在查看的是:好用的MACD幅图:MACD 看透主力+CCI副图指标 贴图 无加密 无未来

MACD 看透主力+CCI(幅图 贴图 无加密)无未来 HJ_01:=REF(LOW,1);
HJ_02:=SMA(ABS(LOW-HJ_01),3,1)/SMA(MAX(LOW-HJ_01,0),3,1)*100;
HJ_03:=EMA(IF(CLOSE*1.3,HJ_02*10,HJ_02/10),3);
HJ_04:=LLV(LOW,30);
HJ_05:=HHV(HJ_03,30);
HJ_06:=IF(MA(CLOSE,58),1,0);
火焰山:=EMA(IF(LOW<=HJ_04,(HJ_03+HJ_05*2)/2,0),3)/618*HJ_06;
吸筹:=IF(火焰山>100,1,火焰山/100);
紫气东来:STICKLINE(吸筹>-150 AND 火焰山>REF(火焰山,1),0,吸筹,4,1),COLORFF0099;
紫气东升:STICKLINE(吸筹>-150 AND 火焰山<REF(火焰山,1),0,吸筹,2,1),COLORLIBLUE;


VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
OBV1:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);
OBV2:=EMA(OBV1,3)-MA(OBV1,9);
OBV3:=EMA(IF(OBV2>0,OBV2,0),3);
MAC3:=MA(C,3);
SHORT:=12;LONG:=26;MID:=9;
DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG)COLORYELLOW ;
DEA:EMA(DIF,MID)COLORFF9900 ;
DRAWICON(CROSS(DIF,DEA),DEA*1.1,1);
DRAWICON(CROSS(DEA,DIF),DEA*1.1,2);
MACD:=(DIF-DEA)*2;
STICKLINE(OBV3>REF(OBV3,1) AND MAC3>REF(MAC3,1),0,MACD,1.8,0),COLORYELLOW;
吸:=XLPL.NOTEXT吸;
拉:=XLPL.NOTEXT拉;
派:=XLPL.NOTEXT派;
落:=XLPL.NOTEXT落;
STICKLINE(吸,0,MACD,0.5,0),COLORLIRED;
STICKLINE(拉,0,MACD,0.5,0),COLORRED;
STICKLINE(派,0,MACD,0.5,0),COLORGREEN;
STICKLINE(落,0,MACD,0.5,0),COLORWHITE;
入1:IF(DIF>REF(DIF,1),DIF,DRAWNULL),COLORRED,LINETHICK2;
入2:IF(DIF<REF(DIF,1),DIF,DRAWNULL),COLORBLUE,LINETHICK2;
低位金叉:=CROSS(DIF,DEA) AND DIF<-0.1;
STICKLINE(低位金叉,0,0.08,6,0),COLORFF00FF;
DRAWTEXT(低位金叉,0.16,' 低位金叉'),COLORWHITE;
JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
STICKLINE(二次金叉,0,0.06,6,0),COLORFFCC00;
DRAWICON(二次金叉,DEA*0.9,1) ;
DRAWTEXT(二次金叉,0.2,' 二次金叉'),COLORYELLOW;
A1:=BARSLAST(REF(CROSS(DIF,DEA),1));
背离:=REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA);
STICKLINE(底背离,0,0.03,6,0),COLOR00FF00;
DRAWTEXT(底背离,0.12,' 底背离'),COLORFF00FF;
A2:=BARSLAST(REF(CROSS(DEA,DIF),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIF,A2+1)>DIF AND CROSS(DEA,DIF);
DRAWTEXT(低位金叉 AND 二次金叉 AND 底背离,0.25,'三全项'),COLOR0000FF,LINETHICK2;


TDXSTEP100:0.2,COLORWHITE,DOTLINE;
0,COLORCYAN;
FJ1:=EXPMEMA(IF(REF(LOW,1)-LOW>0 AND REF(LOW,1)-LOW>HIGH-REF(HIGH,1),REF(LOW,1)-LOW,0),14)*100/EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14);
FJ2:=EXPMEMA(IF(HIGH-REF(HIGH,1)>0 AND HIGH-REF(HIGH,1)>REF(LOW,1)-LOW,HIGH-REF(HIGH,1),0),14)*100/EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14);
FJ3:=EXPMEMA(IF(HIGH-REF(HIGH,1)>0 AND HIGH-REF(HIGH,1)>REF(LOW,1)-LOW,HIGH-REF(HIGH,1),0),14)*100/EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14);
FJ4:=REF(EXPMEMA(IF(REF(LOW,1)-LOW>0 AND REF(LOW,1)-LOW>HIGH-REF(HIGH,1),REF(LOW,1)-LOW,0),14)*100/EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14)+FJ3,1);
FJ5:=EXPMEMA(IF(REF(LOW,1)-LOW>0 AND REF(LOW,1)-LOW>HIGH-REF(HIGH,1),REF(LOW,1)-LOW,0),14)*100/EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14);
FJ6:=EXPMEMA(IF(HIGH-REF(HIGH,1)>0 AND HIGH-REF(HIGH,1)>REF(LOW,1)-LOW,HIGH-REF(HIGH,1),0),14)*100/EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14);
A11:=1.5*(FJ1+FJ2-FJ4)/(FJ5+FJ6);
FJ7:=MA(EXPMEMA(IF(REF(LOW,1)-LOW>0 AND REF(LOW,1)-LOW>HIGH-REF(HIGH,1),REF(LOW,1)-LOW,0),14)*100/EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14),1);
FJ8:=EXPMEMA(IF(HIGH-REF(HIGH,1)>0 AND HIGH-REF(HIGH,1)>REF(LOW,1)-LOW,HIGH-REF(HIGH,1),0),14)*100/EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14);
FJ9:=EXPMEMA(IF(REF(LOW,1)-LOW>0 AND REF(LOW,1)-LOW>HIGH-REF(HIGH,1),REF(LOW,1)-LOW,0),14)*100/EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14);
FJ10:=EXPMEMA(IF(HIGH-REF(HIGH,1)>0 AND HIGH-REF(HIGH,1)>REF(LOW,1)-LOW,HIGH-REF(HIGH,1),0),14)*100/EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14);
FJ11:=EXPMEMA(IF(REF(LOW,1)-LOW>0 AND REF(LOW,1)-LOW>HIGH-REF(HIGH,1),REF(LOW,1)-LOW,0),14)*100/EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14);
FJ12:=EXPMEMA(IF(HIGH-REF(HIGH,1)>0 AND HIGH-REF(HIGH,1)>REF(LOW,1)-LOW,HIGH-REF(HIGH,1),0),14)*100/EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14);
脉冲:MA(A11*(FJ7/FJ8)*(FJ9-FJ10)/MA(FJ11-FJ12,1),1)*0.25,DOTLINE,COLORDDDDDD;


TYP:=(HIGH+LOW+CLOSE)/3;

CCI:(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),COLORWHITE,NODRAW;

NOTEXTCCI:CCI/500,LINETHICK2,COLOREE00EE;

{DIF:EMA(CLOSE,12)-EMA(CLOSE,26),COLORWHITE;
DEA:EMA(DIF,9),COLORYELLOW;
MACD:(DIF-DEA)*2,COLORSTICK;}
0;

{CCI 100 -100 线}
STICKLINE(C>0,100/500,100/500,1,-1),COLORWHITE;
DRAWTEXT(ISLASTBAR,100/500,'CCI正100'),COLORWHITE;
STICKLINE(C>0,-100/500,-100/500,1,-1),COLORWHITE;
DRAWTEXT(ISLASTBAR,-100/500,'CCI负-100'),COLORWHITE;

STICKLINE(C>0,100/500,100/500,1,-1)COLORWHITE;

STICKLINE(C>0,-100/500,-100/500,1,-1)COLORWHITE;

本文来自投稿,不代表本人立场,如若转载,请注明出处:http://www.vszj.net/article/65920.html
本站所有数据资料均来自第三方,仅作为用户获取信息,不构成投资建议,股票实战家不为内容负责。

标签: 好用的MACD幅图:MACD 看透主力+CCI副图指标 贴图 无加密 无未来    通达信公式下载    股票公式